Honda Talon Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys! I have a 2020 1000x4 Live Valve and after 112 miles I’ve already had the signature left front dif leak fixed by the dealer and now more concerning, the suspension caution light came on the dash. I took it to the dealer and a week and a half in they still aren’t sure what’s going on. They said day 2 that it was a steering sensor then day 3.5 that they didn’t know what it was because they needed to update all of the software on their diagnostics and scan tools. Has anyone experienced suspension issues with the live valve system yet?
 

·
Registered
Joined
·
4 Posts
Hey guys! I have a 2020 1000x4 Live Valve and after 112 miles I’ve already had the signature left front dif leak fixed by the dealer and now more concerning, the suspension caution light came on the dash. I took it to the dealer and a week and a half in they still aren’t sure what’s going on. They said day 2 that it was a steering sensor then day 3.5 that they didn’t know what it was because they needed to update all of the software on their diagnostics and scan tools. Has anyone experienced suspension issues with the live valve system yet?
 

·
Registered
Joined
·
4 Posts
hey Im having the same problem light comes on for me after drive on a mostly straight road for 20 or 30 mins. didn't come on when i was in the wood for over in hour going slow around trees and stuff. the dealer has had it since tue, i called today to see and they said it had a steering angle code and that they did the calibration procedure and codes hasn't come back. i also noticed my steering wheel was off center when going on a straight road, they said they did adjustment for that also. They also did a recall
 

·
Registered
Joined
·
4 Posts
hey Im having the same problem light comes on for me after drive on a mostly straight road for 20 or 30 mins. didn't come on when i was in the wood for over in hour going slow around trees and stuff. the dealer has had it since tue, i called today to see and they said it had a steering angle code and that they did the calibration procedure and codes hasn't come back. i also noticed my steering wheel was off center when going on a straight road, they said they did adjustment for that also. They also did a recall. the light was coming on from the start and i only have 115 miles on it a key cycle would get the light out for me most of the time.
 

·
Registered
Joined
·
5 Posts
Picked up my 2020 Talon 1000x4 Live Valve Brand New rolling it off the trailer I noticed the Yellow suspension light that should go off after coming on temporarily was staying on, I purchased out of state, called the dealer absolutely no help. I went over every harness and wire I could find cleaned grounds disconnected battery several times for various lengths of time light did not change. I did find the 4 wire harness that connects at the bottom of the steering column unplugged but after plugging it back in and another battery disconnect for a reset? Nothing changed. Talon is now at a local authorized service dealer and I am waiting on response. Update as I was typing this post Dealer repairing Talon called said it was the Plug I found and that wire inside the plug housing are not connected said it looks like someone or something pulled on the wire said it does detect the steering angle and are ordering me a new end unfortunately it may take all while to get with all that is going on the service rep said but he did say it should be an easy fix. FINGERS CROSSED
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
My dealer called and confirmed my steering angle sensor was messed up as well and a new one is on the way.
 

·
Registered
Joined
·
5 Posts
Picked up my 2020 Talon 1000x4 Live Valve Brand New rolling it off the trailer I noticed the Yellow suspension light that should go off after coming on temporarily was staying on, I purchased out of state, called the dealer absolutely no help. I went over every harness and wire I could find cleaned grounds disconnected battery several times for various lengths of time light did not change. I did find the 4 wire harness that connects at the bottom of the steering column unplugged but after plugging it back in and another battery disconnect for a reset? Nothing changed. Talon is now at a local authorized service dealer and I am waiting on response. Update as I was typing this post Dealer repairing Talon called said it was the Plug I found and that wire inside the plug housing are not connected said it looks like someone or something pulled on the wire said it does detect the steering angle and are ordering me a new end unfortunately it may take all while to get with all that is going on the service rep said but he did say it should be an easy fix. FINGERS CROSSED
Update 5/3/20
Dealer has received and installed new part but light is still on. They said it cleared any current problems but they can't get history to clear causing the light to come on...anyway here I am a couple weeks down the road brand new unit...this aint my favorite moment. Said they are in contact with Honda Western region Rep and Techs? I'll let you all know the outcome when I do.
 

·
Registered
Joined
·
5 Posts
Update 5/3/20
Dealer has received and installed new part but light is still on. They said it cleared any current problems but they can't get history to clear causing the light to come on...anyway here I am a couple weeks down the road brand new unit...this aint my favorite moment. Said they are in contact with Honda Western region Rep and Techs? I'll let you all know the outcome when I do.
Update 5/14/20
Really nothing to update but still waiting, Dealer is emailing back and forth with tech and I suspect only working on my Talon when they remember, currently since the last post they have supposedly been running various tests requested by Honda Tech with no resolution. I have opened a case with Honda but not sure if that's even doing anything one call back then nothing. I am definitely discouraged and frustrated with the pace. I have heard mention of a new Harness front to back the thinking being there's a short but in my mind you could test the various wires on the ends to determine that. In short I'm definitely not feeling the love. I think next week is a case filing with the BBB.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
That’s terrible to hear but I got the exact same service with mine. Honda kept having my dealer ring wires and check parts for weeks until they reluctantly changed the steering angle sensor claiming they’ve only to date had two ever go bad. After three weeks of wasted warranty time in the shop I received my machine took it for a spin with the new sensor and all is well. I really really really hope the poor customer service and extended repair and troubleshooting times are a product of the times with the ongoing pandemic and all, and not something we should be prepared to deal with long term. Best of luck friend keep us in the loop
 

·
Registered
Joined
·
5 Posts
Ok I've got my Talon back and the lights out:). Going for ride tomorrow . So thanks to my wife calling Honda and Dealer....a lot....we kept them moving. Here's a brief rundown, 4 months in shop after purchase, 2 steering angle sensors, 1 wiring harness, countless back and forth tests between Honda and dealer and the problem was.........during manufacture bolt broke off on one of the 4 grounds, worker did no remove part of bolt in hole put in new bolt and so bad ground hard to see but was narrowed down finally by Honda and Dealer running diagnostics unfortunate but success at last. So for anyone who cares this probably won't happen to you (be thankful it wasn't fun). Best of luck to you all.
 
1 - 10 of 10 Posts
Top