Honda Talon Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Has anyone installed an Intellitec battery switch for their second battery? I installed a second battery to power my accessories and wanted to install a master shut off switch with a reverse polarity rocker switch to the battery switch. When testing it outside the Talon, it worked with a test light. However when I installed it, it did not work it was completely dead. When I disconnected the battery from the switch and tested it, you could hear it "bang" and activate or disconnect. Then when I hooked the battery back up, the switch was dead again. Any thoughts on what is happening? Thank you
 

·
Registered
Joined
·
363 Posts
Hi - I think that this is the latching relay setup and you are swapping polarity to engage/dis-engage your accessories via the relay?
Take this with a grain of salt, fuses all good and you have at least 11 volts on battery?

After that, I’d suggest to double check the wiring even though it only a couple of wires, disconnect the load wires to try and eliminate stuff, also check you have continuity thru coil and the coil isn’t burnt up.
Is this connected so the talon charges this batree as well?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Hi - I think that this is the latching relay setup and you are swapping polarity to engage/dis-engage your accessories via the relay?
Take this with a grain of salt, fuses all good and you have at least 11 volts on battery?

After that, I’d suggest to double check the wiring even though it only a couple of wires, disconnect the load wires to try and eliminate stuff, also check you have continuity thru coil and the coil isn’t burnt up.
Is this connected so the talon charges this batree as well?
Thank you for validating my wiring was correct. Went out this morning and traced all wire. Found my mistake in my positive to the switch was hokked up to after the switch. Hense when it was turned off, there was no power. Basically i was an idiot on my wiring. Thank you for responding as I was not 100% sure I had the overall set up correct.
 

·
Premium Member
Joined
·
1,119 Posts
I suggest contacting the company and having pictures of your installation, ln addition to the hand drawn wiring diagram. If the company supplied a diagram that would help on the forum. Good luck and hope this is an easy fix. :)
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top