Honda Talon Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Good evening
My 2021 1000S4X Talon engine has ran perfect for 790 miles, yesterday I took it out to the ranch and unloaded and started up a fairly mild incline the engine stalled under slight loading but idled fine with no load, in park the engine would rev with no noticeable miss or roughness, I tried it again in low range same result.
Anyone have an idea what might cause this? Maybe starving for fuel under a load, plugged fuel filter or bad fuel pump?
I'm waiting for a shop manual now, but any help would be much appreciated
Thanks for looking
jpgrifles
 

·
Registered
Joined
·
5 Posts
Good evening
My 2021 1000S4X Talon engine has ran perfect for 790 miles, yesterday I took it out to the ranch and unloaded and started up a fairly mild incline the engine stalled under slight loading but idled fine with no load, in park the engine would rev with no noticeable miss or roughness, I tried it again in low range same result.
Anyone have an idea what might cause this? Maybe starving for fuel under a load, plugged fuel filter or bad fuel pump?
I'm waiting for a shop manual now, but any help would be much appreciated
Thanks for looking
jpgrifles
Have you checked the recalls on it ? Some have one for fuel pump.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Have you checked the recalls on it ? Some have one for fuel pump.
Good afternoon all
Thanks again Randman for the air cleaner tip, that was the dirtiest filter I've seen, I never dreamed that filter would be ready to change at 790 miles, I cleaned it with K and N filter cleaner dried it and oiled it, reinstalled and test drove up the street and back the engine ran fine under hard acceleration, I have a new filter on the way as I don't trust the paper filter for more than a test drive, my new filter will be here on Thursday then back to the Ranch for ground squirrel shooting and a real test drive on some steep hills.
21LVX, I didn't get a recall for the fuel pump I've done the steering recall and the intake clamp recall and took it back to the dealer for excessive play in the radius rods that turned out to be normal.
Again thanks for the help
jpgrifles
 

·
Registered
Joined
·
51 Posts
Good afternoon all
Thanks again Randman for the air cleaner tip, that was the dirtiest filter I've seen, I never dreamed that filter would be ready to change at 790 miles, I cleaned it with K and N filter cleaner dried it and oiled it, reinstalled and test drove up the street and back the engine ran fine under hard acceleration, I have a new filter on the way as I don't trust the paper filter for more than a test drive, my new filter will be here on Thursday then back to the Ranch for ground squirrel shooting and a real test drive on some steep hills.
21LVX, I didn't get a recall for the fuel pump I've done the steering recall and the intake clamp recall and took it back to the dealer for excessive play in the radius rods that turned out to be normal.
Again thanks for the help
jpgrifles
You are welcome!
Are you running a K&N main filter or the factory filter? I have never heard of anyone cleaning a factory filter!

Lets hope you are running a factory filter. A K&N by itself as the main filter will not filter properly and will allow dirt into the engine!

One of your next projects should be to relocate the factory air intake so you don't have to keep buying expensive factory filters. Do a search on the site here for pre-filters or air intake relocation.

Honda missed the mark with this one. The factory intake location is in front and slightly above the passenger rear wheel. With the intake in this location, it draws dusty air into the intake that is kicked up from the front tires. This is why you used up a filter at 790 miles!

I am running the KWT Particle seperator which supposedly stops 95% of the dust before it hits the main filter. Expensive but in my opinion worth it. It's amazing how much dust I empty out of it after a ride!
 

·
Registered
2021 Talon X4, 32" BFG's and two car seats
Joined
·
42 Posts
Good afternoon all
Thanks again Randman for the air cleaner tip, that was the dirtiest filter I've seen, I never dreamed that filter would be ready to change at 790 miles, I cleaned it with K and N filter cleaner dried it and oiled it, reinstalled and test drove up the street and back the engine ran fine under hard acceleration, I have a new filter on the way as I don't trust the paper filter for more than a test drive, my new filter will be here on Thursday then back to the Ranch for ground squirrel shooting and a real test drive on some steep hills.
21LVX, I didn't get a recall for the fuel pump I've done the steering recall and the intake clamp recall and took it back to the dealer for excessive play in the radius rods that turned out to be normal.
Again thanks for the help
jpgrifles
Randman is right. I would not run a K&N as the primary filter. They do not remove enough dirt! Most folks run the factory Honda filter as the primary filter with some sort of pre-filter or particle separator as a secondary filter.
I had 300 Arizona miles on my first Honda filter when it needed to be changed. I have 900 miles on my second Honda filter while simultaneously running a UNI pre-filter and the Honda filter is barely dirty.
 

·
Registered
Joined
·
27 Posts
Good evening
My 2021 1000S4X Talon engine has ran perfect for 790 miles, yesterday I took it out to the ranch and unloaded and started up a fairly mild incline the engine stalled under slight loading but idled fine with no load, in park the engine would rev with no noticeable miss or roughness, I tried it again in low range same result.
Anyone have an idea what might cause this? Maybe starving for fuel under a load, plugged fuel filter or bad fuel pump?
I'm waiting for a shop manual now, but any help would be much appreciated
Thanks for looking
jpgrifles
Had a similar problem with my 21 1000x-4 and after having it in the shop twice for 2 months ( first one was supposed to change all oils and spark plugs) it turned out to be the spark plug wire wasn’t seated properly and the spark plug ceramic Shattered. I changed them out and haven’t had any issues for over 300 hrs
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Randman is right. I would not run a K&N as the primary filter. They do not remove enough dirt! Most folks run the factory Honda filter as the primary filter with some sort of pre-filter or particle separator as a secondary filter.
I had 300 Arizona miles on my first Honda filter when it needed to be changed. I have 900 miles on my second Honda filter while simultaneously running a UNI pre-filter and the Honda filter is barely dirty.
Good evening all
Yes, I cleaned the factory filter using K and N filter cleaner, it cleaned up quite nicely with no obvious damage to the paper element after drying and oiling with K and N filter oil I reinstalled it and test drove the talon about a quarter mile on a paved fairly dust free city street to see if the problem was solved, it ran very well, no longer cut out.
I wouldn't recommend cleaning OEM filters for permanent use as the paper element might collapse and tear letting dirty air directly into your engine.
The OEM filter will be replaced with a K and N with a prefilter installed before I go back to the ranch with frequent filter checks to be sure I'm not getting dirt past the filter'
Thanks again you guys pointing me in the right direction.
jpgrifles
 

·
Registered
Joined
·
50 Posts
Never go K&N. In the world of engine performance there is only one way to get more power and that is more air. More air means more fuel you can cram into the combustion chamber. K&N gives out performance gain promises and they do it by having a high flow, which means lower filtration, filter. Buy a high quality filter or OEM. It will cost you all but 3 horsepower to run a good filter with a low micron filtration but will add to your engines longevity. You have have power gains now with a K&N or you can maintain factory power levels for a long time with an OEM or high quality filter.
 
1 - 12 of 12 Posts
Top