Honda Talon Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello Everybody,

I’m new to the forum and appreciate any help given. After taking a swim with my 2020 Talon X4 my display has stopped working. It’s a bit cloudy behind the dash, like moisture, so I figured water got it. Has anybody had this problem? Any thoughts on troubleshooting or ways to fix it?
Cart runs fine, no issues mechanically but I cant see current state of vehicle anymore. No RPMs, no speed, no gear, no hours, no nothing. It doesn’t power up.

Many thanks in advance,
 

·
Registered
Joined
·
7 Posts
Hello Everybody,

I’m new to the forum and appreciate any help given. After taking a swim with my 2020 Talon X4 my display has stopped working. It’s a bit cloudy behind the dash, like moisture, so I figured water got it. Has anybody had this problem? Any thoughts on troubleshooting or ways to fix it?
Cart runs fine, no issues mechanically but I cant see current state of vehicle anymore. No RPMs, no speed, no gear, no hours, no nothing. It doesn’t power up.

Many thanks in advance,
Mine did the same thing. I took it back to the dealer and they replaced it at no cost to me.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hello KB,


I ended buying a new display as dealer was backup for more than 6 weeks. I was thinking of adding some kind of non conductive spray to the board to prevent future water intrusion issues. Well see how it goes. Thanks for the input.

Sent from my Pixel 4 XL using Tapatalk
 
1 - 4 of 4 Posts
Top